Zur Übersicht zurück
Gelöst

Maltego Hub Is down

Aug 20, 2026 at 5:41am UTC
Betroffene Dienste
Data Pass

Gelöst
Aug 20, 2026 at 7:20am UTC

We’re back!

Everything should be up and running. Thanks for bearing with us.

Erstellt
Aug 20, 2026 at 5:41am UTC

Hi everyone!

Maltego Hub is down. We’re investigating an issue, and We’re working to fix the problem as quickly as we can. We’ll share another update shortly.