Back to overview
Resolved

Minor incident - Maltego ID Backend

Aug 16, 2026 at 2:00am UTC
Affected services
Maltego ID

Resolved
Aug 18, 2026 at 4:00am UTC

We’re back! Long term fixes are applied and should be up and running. Thanks for bearing with us.

Created
Aug 16, 2026 at 2:00am UTC

We’re having degraded performance with Maltego ID Backend. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.