Back to overview
Degraded

OSINT Industries Down

May 12, 2026 at 1:26pm UTC
Affected services
Data Pass

Resolved
May 13, 2026 at 11:28am UTC

We’re back! [
OSINT Industries should be up and running. Thanks for bearing with us.

Created
May 12, 2026 at 1:26pm UTC

We’re having some trouble with the OSINT Industries Data Source. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.