Back to overview
Degraded

Pipl Transform are down!

May 21, 2026 at 10:24am UTC
Affected services
Data Pass

Resolved
May 21, 2026 at 1:26pm UTC

Pipl Transforms are back online. If you still face any issues, reach out at support.maltego.com

Created
May 21, 2026 at 10:24am UTC

Pipl is down for most users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.